ASUDBase (руководство)

Материал из TekonWiki
Перейти к: навигация, поиск

Содержание

ОБЩИЕ СВЕДЕНИЯ

Назначение программы

ASUDBase является программным модулем в составе программного обеспечения автоматизированной системы управления и диспетчеризации АСУД-248 производства НПО Текон-Автоматика.

Программа представляет собой исполняемый файл asudbase.exe и работает под управлением ОС Windows (XP, Vista, 7, 8, 10).

Программа позволяет интерпретировать в графической форме или в виде отчетов информацию, полученную с приборов учета энергоресурсов (теплосчетчиков, водосчетчиков, электросчетчиков, газосчетчиков и т.п.), подключенных к АСУД. 

Данные с приборов учета хранятся в специализированной SQL-ориентированной БД под управлением высокопроизводительной СУБД Firebird 2.1.

Основные функции программы:

  • настройка и управление БД коммерческой информации общедомовых и поквартирных приборов учета;
  • построение графиков по анализируемому параметру (расход, температура, давление и т.д.) или группе однотипных параметров за любой интервал времени;
  • анализ качества предоставляемых услуг;
  • создание табличных отчетов с возможностью экспорта в форматыtxt,doc,csv;
  • печать на принтере полученных графиков и отчетов;
  • генерирование специализированных отчетов для передачи данных энергопотребления в ЕИРЦ, МОЭК, ЭНЕРГОСБЫТ, АСКУПЭ и т.п.;
  • поддержка работы в компьютерной сети, возможность подключения к удаленной БД.


Установка программы

Программа устанавливается автоматически в составе ПО АСУД (C:\1Tekon\ASUD Scada\OPC Server\asudbase.exe).

В случае отдельной установки на выделенном ПК, необходимо создать папку, например, C:\1Tekon, и скопировать в нее два файла: asudbase.exe и fbclient.dll. Файл fbclient.dll может быть скопирован с ПК, на котором установлено СПО АСУД (например, C:\1Tekon\ASUD Scada\OPC Server\fbclient.dll). Файл fbclient.dll после копирования следует переименовать в gds32.dll

Обновление программы ASUDBase осуществляется простой заменой файла asudbase.exe

Под управлением ОС Windows XP, рекомендуется отключить функцию «Восстановления системы» для диска C: или отредактировать файл C:\Windows\System32\Restore\FileList.xml, убрав строчку, относящуюся к файлам типа GDB.


Первый запуск программы (запуск программы после обновления)

Первый запуск программы следует выполнять от имени пользователя с административными правами.

В случае если программе не удастся подключиться к БД, вы увидите сообщение об ошибке.

Asudbase 1.png

Рисунок  – Первое подключение к БД

 

Выберите меню Файл / Подключиться к БД и укажите путь к файлу БД (по умолчанию IP: 127.0.0.1 Путь: C:\1Tekon\ASUD Scada\OPC Server\original.gdb).

Если у вас отсутствует файл БД по указанному пути, следует скопировать пустую БД из папки C:\1Tekon\ASUD Scada\OPC Server\DB\ в папку C:\1Tekon\ASUD Scada\OPC Server\.

Программа ASUDBase может содержаться в себе обновление для БД учетной информации. Функция обновления БД позволяет внести изменения в программный код процедур БД в случае выхода обновлений. Внесение обновлений связано с изменением генерируемых программой отчетов, добавлением новых функций.

После запуска программы выполняется сравнение текущей версии БД с обновлением доступным в программе. В случае если БД нуждается в обновлении, пользователь будет проинформирован об этом в строке статуса главного окна программы.

Asudbase 2.png

Рисунок  – Проверка версии БД после запуска программы

Для корректной работы программы версия БД должна быть всегда актуальной.

Для выполнения обновления БД необходимо выбрать меню Настройка/Работа с БД/Обновление. Программа проверит текущую версию БД и по необходимости внесет требуемые изменения.

Обновление БД возможно только для локальной БД. В последствии программа может быть запущена под любым пользователем (права администратора не обязательны).



Работа программы

Логика работы пользователя с программой основывается на следующей схеме:

  • выбор объекта учета (здание);
  • экспорт данных или выбор системы учета;
  • выбор параметра (построение графика) или выбор табличного отчета.

Основные окна программы представлены на рисунках 

Первая закладка Шаг1. Выбор адреса содержит список всех адресов зарегистрированных в БД, расположенных в виде раскрывающегося списка. Для того чтобы перейти к следующей закладке необходимо выбрать дом, выделив его мышкой (выполнить одинарный клик) и нажать кнопку Далее или выполнить на доме двойной клик мышкой.

Asudbase 3.png

Рисунок  – Основное окно программы. Выбор адреса (Шаг 1).

 

Asudbase 4.png

Рисунок  – Анализ параметров выбранного прибора учета (Шаг 2).

 

Вторая закладка Шаг2. Параметры выборки содержит список всех приборов учета, зарегистрированных в БД по данному адресу, с указанием систем, по которым ведутся измерения: раздел Анализируемые системы.

В случае работы с поквартирными расходомерами необходимо выбрать номер интересующей квартиры из выпадающего списка Квартира (Кв.). После этого в разделе Анализируемые системы появятся данные, относящиеся только к выбранной квартире (иначе данные по вводу в дом - квартира номер 0).

После выбора системы прибора учета справа, слева отобразятся измеряемые параметры данной системы. В таблице отображаются параметры, полученные с прибора в процессе его последнего опроса При этом все параметры разделены на 4-е группы: Мгновенные (Мгн.), Часовые (Час), Суточные (Сут.), Месячные (Мес).

Вкладка «Мгн.»  содержит мгновенные (текущие) параметры, измеряемые прибором учета (эти значение читаются с прибора наиболее часто).

Вкладки «Час.», «Сут.», «Мес.» - содержат соответственно часовые, суточные и месячные архивы выбранного прибора учета.

Следует иметь ввиду, что наличие или отсутствие данных на той или иной вкладке зависит от типа прибора учета.

Выбрав архивный параметр, можно построить его график на выбранном интервале, перейдя на Шаг3.

Asudbase 5.png

Рисунок  – Графическое представление данных (Шаг 3).

 

Отображаемые параметры имеют осмысленное наименование и указание единицы измерения, например (см. рисунок ), 

Tпод (С.) - Температура подающего трубопровода в градусах Цельсия. 
Vобр (куб.м) - Объем теплоносителя прошедшего в обратном трубопроводе в кубических метрах.

Некоторые параметры имеют специально значение, например, 

Err32    код ошибки прибора учета (значение данного параметра расшифровывается при формировании отчетов).
Count - общее число импульсов на входе концентратора КИР (или число импульсов на входе концентратора КИР с начала часа).

Если в названии параметра присутсвует  «(НИ)»   это говорит о том, что значение параметра представлено нарастающим итогом. Иначе (значение параметра)   это среднее значение за интервал выбора (для параметров температура, давление и т.п.) или значение расхода (для параметров объем, масса и т.п.). Под интервалом выбора здесь понимается час - для часового архива (кнопка «Час»), сутки - для суточного архива (кнопка «Сут.») и т.д.

Если данных нет ни в одной вкладке (все кнопки - неактивны) выбранной системы прибора     это говорит о том что с прибора учета нет данных.

Подробнее рассмотрим данные, отображаемые импульсным прибором учета, который подключен к концентратору КИР-16.

Предположим в таблице Анализируемые системы был выбран счетчик ХВС, прибор CB Minol, подключенный к входу номер 11 концентратора номер 206.

 

Asudbase 6.png


Рисунок – Пример данных импульсного прибора учета, подключенного к КИР-16.

 

В общем случае во вкладке Мгн. (Мгновенные) отображаются два параметра Count. 

Параметр Count   содержит общее число импульсов с  начала текущего часа. Параметр Count (НИ) содержит общее число импульсов на время последнего опроса концентратора.

Период обновления мгновенных данных в БД для концентраторов КИР-16 составляет порядка 10 минут.

Во вкладке Час. (Часовые) содержатся данные расхода, выбранного прибора за последний час.

 

Asudbase 7.png

Рисунок – Пример данных импульсного прибора учета, подключенного к КИР-16.

 

Расход с 11 часов до 12 часов был равен 0.

По данным часового расхода может быть построен график. Для этого следует выбрать параметр Vпод, указать временной интервал , например, текущий день и перейти на Шаг 3.

Рассмотрим вариант, что после выбора импульсного прибора в левом окне Измеряемые параметры отображается либо 0, либо ничего не отображаться.

В случае если не отображается ничего   это значит, что в сумматоре данного канала КИР записано значение 0 и ни одного импульса по данному каналу еще не проходило.

В случае если отображается не нулевое значение, но дата во вкладках Мгн, Час., значительно отличается от текущей (при этом заведомо известно что КИР исправен, т.е. передает данные в систему)   это означает что раньше по данному каналу КИР шел расход, но в последствие КИР был сброшен, например, по питанию (дата сброса скорее всего соответствует дате, отображаемой в левом окне) и до настоящего момента ни одного импульса по данному каналу КИР еще не проходило.


Подключение к удаленной БД

Для подключение к другой БД расположенной на этом же или другом компьютере доступном по компьютерной сети следует открыть меню Файл \ Подключить к БД .

Asudbase 8.png

Рисунок – Подключение к БД.

 

В открывшемся окне заполнить поля: 

  • IP - IP- адрес компьютера, на котором расположена БД.
  • Название - любое осмысленное название БД.
  • БД - путь к файлу БД на удаленном компьютере.

Нажать кнопку «Ок».

Выполняемые расчеты и измерения

Концентраторы КЦС, КЦС-IPM, КУН-IPM, а также программа ASUDBase не производят расчетов (измерений) для приборов учета (теплосчетчиков, электросчетчиков и т.п.), опрашиваемых указанными концентраторами. Учетные данные аккумулируемые в БД и отображаемые программой ASUDBase полностью соответствует архиву прибора учета (или данным его текущих измерений). 

Расчет производится только для импульсных приборов учета, подключенных к концентраторам типа КИР.

На основе значения общего числа импульсов, поступаемых с входа КИР, программа вычисляет почасовой расход по следующему правилу.

Расход = K * (ЧислоИмпульсов2 - ЧислоИмпульсов1)         (1),

где:
ЧислоИмпульсов2 - число импульсов на конец часа.
ЧислоИмпульсов1 - число импульсов на начало часа.
К - коэффициент преобразования числа импульсов в единицу измеряемой величины (задается при настройке прибора учета в БД, подробнее см. далее).

В БД хранится соответственно значение почасового расхода для каждого канала КИР.

Для возможности вычисления последующего показания импульсного прибора учета, подключенного к КИР, помимо расхода (посчитанного на основе импульсов) необходимо знать еще и начальное показание прибора учета (отображаемое на его табло). Данное начальное показание должно быть введено в систему на этапе ее настройки (при регистрации канала автоматически добавляется его начальное значение 0). Тогда последующее показание вычисляется по следующей формуле:

Показание2 =  Показание1 + Расход1-2                 (2)
где:
Показание1   начальное показание прибора учета введенное в системе
Расход1-2   расход  прибора вычисленный по формуле (1) за интервал времени со снятия (фиксации) Показания1  до момента, на который необходимо определить Показание2.
Показание2    вычисленное показание прибора на любой предыдущий момент времени (больше даты Показание1 и до настоящего времени).

Подробнее см. раздел Первоначальные показания импульсных приборов учета (далее).

НАСТРОЙКА

При работе АСУД в БД сохраняется информация только с тех, подключенных к системе приборов коммерческого учета (теплосчетчиков, водосчетчиков и т.п.), которые зарегистрированы в БД. 

Регистрация должна быть осуществлена при первом запуске или при добавлении, изменении, удалении расходомера и подразумевает под собой внесение служебной информации в БД. 

Конфигурирование БД должен выполнять ответственный специалист, т.к. неправильное проведение операции может привести к удалению уже накопленных данных.

Действия по внесению изменений в БД выполняются в разделе Настройка. Для доступа к разделу необходимо ввести пароль (по умолчанию 0000).

Общий принцип регистрации:

  • Указать типы импульсных расходомеров (если используются);
  • Указать адресную информацию.
  • Указать концентратор, расположенный по данному адресу.
  • Указать приборы учета, подключенные к данному концентратору.
  • Указать каналы измерений данных приборов, с привязкой к месту установки (номеру квартиры), лицевому счету и т.п.
  • Указать первоначальные показания (значение расхода отображаемое на табло прибора учета) для импульсных приборов учета, подключенных к концентраторам КИР.

Внимание! Для каждого прибора учета, регистрируемого в системе должен корректно указываться его серийный идентификационный номер.  



Редактирование типов импульсных расходомеров

В случае настройки системы учета на основе данных импульсных приборов учета (подключаемых к концентраторам КИР), следует зарегистрировать в БД типы установленных на объекте импульсных расходомеров.

Для этого необходимо выбрать раздел меню Настройка\Импульсные расходомеры. 

В открывшемся окне следует указать идентификатор (просто уникальный номер), название расходомера, коэффициент пересчета количества импульсов в величину измеряемого ресурса, число тарифов (оставить 1 - в данный момент не используется). Идентификатор расходомера следует выбирать исходя из приведенных в окне комментариев. Идентификатор ID должен быть уникальным.

Цена импульса для водосчетчиков указывается в пересчете на куб.м. Т.е. для приборов с ценой импульса: 

1 л/имп следует указывать 0,001;
10л/имп   0,01; 
100л/имп – 0,1.

Asudbase 9.png

Рисунок  – Окно регистрации импульсных расходомеров


 

Цена импульса для теплосчетчиков  указывается в пересчете на Гкал или кВт*ч в зависимости от типа подключаемого прибора учета и настроек программы. 

Поскольку взаиморасчеты по теплу осуществляются в Гкал, рекомендуется установить флажок Отчеты \  Настройка отчетов \ Квартиры тепло в Гкал  и указывать цену импульса в пересчете на Гкал. Также в Гкал следует впоследствии вводить первоначальные показания приборов учета.

Если же установлен теплосчетчик иностранного производства, отображающий на цифровом табло данные в кВт*ч с ценой импульса равной  (или кратной) кВт*ч, то для удобства сравнения показаний счетчик / система  рекомендуется снять  флажок Отчеты \  Настройка отчетов \ Квартиры тепло в Гкал . Также в кВт*ч  следует впоследствии вводить первоначальные показания приборов учета.

Внимание! Сама по себе установка флажка Отчеты \  Настройка отчетов \ Квартиры тепло в Гкал  - не выполняет никаких числовых преобразований в случае с импульсными приборами учета.  А лишь определяет  отображение параметра Q (Гкал) или W (кВт*ч) в окне Шаг 2.  Пересчет импульсов выполняется на основе введенного коэффициента пересчета.

Добавление адресной информации

Выбрать меню Настройка\Регистрация. 

Откроется окно Адреса. В окне отображаются все адреса строений и приборы учета, зарегистрированные на данном объекте. Данная закладка является основной в процессе редактирования БД рисунок 10.

Редактирование улиц.

Для добавления новой улицы в БД необходимо выбрать любую уже зарегистрированную улицу (если она есть) и ввести в разделе Улица (микрорайон) требуемое название. По необходимости также заполнить поля: коды БТИ, ТБН (код улицы по Московскому городскому справочнику, используется в отчетах при передаче данных в ЕИРЦ). Нажать кнопу Добавить. Название улицы появится в списке зарегистрированных адресов.

Для редактирования названия существующей улицы следует выбрать ее в списке, после этого внести необходимые изменения и нажать кнопку Изменить.

Для удаление улицы следует выбрать ее в списке и нажать Удалить.

Следует отметить, что удалять можно только улицы, на которых нет зарегистрированных строений (домов), иначе, предварительно необходимо удалить все строения (дома).

Кнопка «?» отображает московский классификатор кодов улиц по состоянию на 2006 год.

Asudbase 10.png

Рисунок – Окно редактирования адресной информации БД.

Редактирование домов.

Для добавления нового дома необходимо выбрать улицу, на которой расположен регистрируемый дом, и заполнить поля в разделе Дом. Обязательно должно быть заполненным одно из полей Номер, Строение, Корпус; остальные поля являются необязательными. Нажать кнопку Добавить.

Для редактирования данных необходимо выбрать требуемое строение из списка, внести необходимые изменения в разделе и нажать кнопку Изменить.

Для удаления здания необходимо выбрать его из списка зарегистрированных адресов и нажать кнопку Удалить. Удалить можно любой дом, если у него нет зарегистрированных концентраторов (приборов).

В случае не верной регистрации, существует возможность переноса дома с одной улицы на другую. Для этого необходимо просто захватить дом мышкой (выполнив щелчок левой кнопкой мыши и не отпуская кнопки), перетащить его на требуемую улицу (отжать кнопку мыши).

Добавление приборов (концентраторов).

После ввода адресной информации необходимо указать концентраторы и подключенные к ним приборы учета.

Внимание! В данном разделе могут быть зарегистрированы все типы концентраторов (приборов учета) за исключением КИР-КМ, КИР-РП и приборов подключенных к ним. Для регистрации указанных концентраторов следует после ввода адресной информации воспользоваться меню «Настройка \ Концентраторы КИР \ Радио КИР» (подробнее см. далее).

Для добавления нового концентратора необходимо выбрать дом из списка адресов и перейти на закладку Концентратор/Прибор (добавление возможно только при выборе дома).
 

TL-концентраторы

В разделе Концентратор следует указать номер концентратора и тип прибора учета. 

Если добавляемый концентратор – КИР, то в поле прибор следует выбрать Импульсный (а непосредственно подключенный прибор учета будет определен далее при настройке каналов измерений).

Номер для проводных концентраторов в общем случае указывается в виде трех цифр, например, 102, 303, 425.

Внимание! Если проводной концентратор (КИР-16, КИР-РП, КЦС, КЦМ) подключен к КИО (КИО-2М) работающему в режиме ретрансляции данных, то номер концентратора при регистрации в БД следует указывать в следующем виде

Номер в БД = ID_контроллера * 10 000 + Номер концентратора
, где 
ID_контроллера - идентификатор контроллера в конфигураторе ОРС-сервера.
Номер концентратора - обычный трехзначный номер концентратора.
Например, 10102, 20308 и т.п.



IP-, RS-устройства

При настройке прибора учета, подключаемого по интерфейсам RS-232/485 M-bus к IP-концентраторам, следует установить флажок «IP соединение» и указать дополнительные параметры:

  • Мастер устройство: 
    • КУН-IP, 
    • КЦС-IP, 
    • КЦС-IPM, 
    • Прямое подключение (если устройство подключено к системе напрямую по IP-сети).
    • IP адрес   IP-адрес Мастер устройства, к которому подключен прибор.
    • Настройки интерфейса – настройки интерфейса скорости , четности и т.п. подключаемого прибора учета.
    • RS-идентификатор – номер прибора учета в сети RS-сети.
    • Интервал (мин.) – интервал опроса прибора учета в минутах.
    • Читать архив –тип архива, который следует читать с прибора учета. (Ч – часовой, Д – дневной, М – месячный). (В настоящее время параметр не используется, следует установить все флажки).
    Например, для концентратора КИР-RS, подключенного к концентратору КЦС IPM с адресом 192.168.254.11, следует указать следующие настройки :
    • Мастер устройство: КЦС-IPM.
    • IP адрес: 192.168.254.11
    • Настройки интерфейса: RS-485 (1) - если КИР подключен к разъемам А0-В0, 9800-8-1.
    • RS идентификатор – 0 (номер выставленный перемычками на КИР-RS).
    • Интервал (мин.) – 30.
    Номер концентратора в этом случае следует выбирать самостоятельно из диапазона 901..999, 1901…1999, 2901...2999 и т.п. (эти номера используются лишь для регистрации в БД устройств, подключенных IP-концентраторам). Если номер не указан (0), он будет сгенерирован автоматически, при установке флажка «IP-соединение». Нажать Добавить. После регистрации номер концентратора появится в списке зарегистрированных адресов (слева). Причем если это КЦС, то появится запись: номер концентратора и тип теплосчетчика (например, «808 ВИС.Т»). Если регистрируется КИР, то появится просто запись с номером концентратора (например, «803»).
    Asudbase 11.png

    Рисунок – Окно редактирования БД.

     

    Asudbase 12.png

    Рисунок – Окно редактирования БД.

    Для зарегистрированного концентратора существует возможность изменения его номера и типа подключенного прибора учета. Для этого выберите требуемый концентратор, в разделе Концентратор выполните необходимые изменения и нажмите кнопку Изменить. 

    Для удаления концентратора из списка зарегистрированных необходимо выбрать его и нажать кнопку Удалить.

    В случае неверной адресной регистрации концентратора, существует возможность его переноса из одного дома в другой. Для этого необходимо просто захватить концентратор мышкой (выполнив щелчок левой кнопкой мыши и не отпуская кнопки), перетащить его в требуемый дом.


    Параметры прибора учета

    Далее переходим к разделу Прибор на этой же вкладке.

    В случае если был добавлен теплосчетчик, по умолчанию будет зарегистрирована одна его система: «Отопление». Поскольку современные теплосчетчики обычно являются многоконтурными, необходимо самостоятельно добавить все его оставшиеся теплосистемы.


    Asudbase 13.png

    Рисунок – Окно редактирования БД.

    Необходимо выбрать устройство (например, «808 ВИСТ»), заполнить поля Номер канала (тепосистемы), Серийный номер, Система. 

    К выбору следующие системы: Отопление, ГВС, ХВС с указанием Пр. (прямая) или Обр. (обратка), 1_зона и 2_зона – для двухзонных ГВС/ХВС, Электроэнергия, Газ.

    В случае необходимости внесения изменений выберите требуемую систему, внесите необходимые изменения, нажмите Изменить.

    Чтобы удалить систему выберите ее в списке зарегистрированных адресов и нажмите кнопку Удалить.

    В случае если был добавлен концентратор КИР, необходимо для каждого канала определить тип подключенного импульсного расходомера, его серийный номер и тип системы.

    В поле «Номер квартиры» следует указывать номер квартиры, в которой установлен прибор учета. При этом:

    • 0 – все общедомовые приборы учета
    • 1..1999 – жилые квартиры
    • 2000..2999 – нежилые помещения
    • 3000..3999 – места общего пользования.

    Для каждого прибора учета можно по необходимости указать комментарий в поле «Ком.» (текстовое поле до 32 символов). Кнопки «?» позволяют проверить встречаются ли уже в БД указанные параметры.

    Лиц. счет - номер лицевого счета (текстовое поле до 32 символов).

    Подробно процесс настройки различных приборов рассмотрен в Приложении А.

    Дополнительные способы регистрации импульсных приборов учета

    Существует несколько способов регистрации импульсных приборов учета, подключенных к концентраторам КИР: 

    1. с помощью меню Настройка\Регистрация;
    2. с помощью заполнения таблицы подключений;
    3. с помощью импорта данных из специализированных файлов.

    Пункт 1 был рассмотрен ранее. Пункты 2, 3 рассматриваются далее.


    Таблица подключений (проводные КИР-16)

    После выбора дома в окне «Шаг 1» программы следует выбрать раздел меню Настройка/Концентраторы КИР/Проводные КИР. 

    В открывшемся окне будут отражены в табличном виде приборы учета, зарегистрированные по указанному адресу, и подключенные к концентраторам КИР-16.

    Для добавления новой записи следует выполнить клик мыши на пустой строке (или нажать кнопку Добавить, для добавления новой строки) заполнить Карточку регистрации и нажать кнопку Ок.
    Карточка регистрации:

    Квартира – номер квартиры (аналогично п.2.3, рассмотренному ранее) .
    Ресурс – ХВС, ГВС и т.п.
    Тип ИПУ – необходимо выбрать тип импульсного прибора учета из списка. Добавить новый прибор в список можно в разделе меню Настройка / Импульсные расходомеры.
    Кимп – справочный параметр, отражает цену импульса выбранного прибора учета.
    Серийный номер – серийный (идентификационный) номер прибора учета.
    Комментарий – любой комментарий до 32 символов (заполнять не обязательно).
    Номер КИР – номер концентратора, например 102, 215.
    Вход КИР – номер (1..16) входа концентратора, к которому подключен прибор.

    Asudbase 14.png

    Рисунок – Окно регистрации проводных КИР.

    Работа со строками:

    Удалить – удаляет данные о регистрации выбранного прибора учета.
    Вставить – вставка пустой строки.
    Добавить – добавить пустую строку в конец.
    Копия – скопировать в карточку регистрации данные верхней строки.

    Для получения информации о всех приборах учета подключенных к концентратору, следует указать его номер в поле справа и нажать кнопку «Получить».

    Таблица подключений (радио КИР)

    После выбора дома в окне «Шаг 1» программы следует выбрать раздел меню Настройка/Концентраторы КИР/Радио КИР. 

    В открывшемся окне будут отражены в табличном виде приборы учета, зарегистрированные по указанному адресу, и подключенные к радио концентраторам КИР-КМ (КИР-РП).

    Работа с таблице в целом аналогична описанной в п.2.4.1



    Импорт конфигураций импульсных приборов учета

    Существует возможность выполнить импортирование данных о регистрации приборов учета из подготовленного заранее файла. Это бывает удобно, если на этапе монтажа системы была подготовлена соответствующая монтажная таблица с данными о регистрации устройств.

    Импорт данных приборов учета может быть осуществлен из специализированных файлов формата Excel или CSV. 

    Реализована поддержка следующих типов файлов данных: 

    1. данные о регистрации импульсных приборов учета (только для концентраторов КИР-16, КИР-КМ, КИР-РП);
    2. данные о первоначальных показаниях импульсных приборов учета;
    3. данные серийных номеров импульсных приборов учета (для концентраторов КИР-16);
    4. данные ADFWeb   данные о регистрации приборов учета (M-bus), подключенных через конвертеры ADFWeb HD67044.

    Для выполнения импорта следует на Шаге 1 выбрать дом, далее выбрать меню Настройка \ Концентраторы КИР \ Импорт конфигураций. В открывшемся окне следует выбрать загружаемый файл с данными, тип данных из выпадающего списка, нажать кнопку Загрузить.
    Данные о регистрации.

    Структура файла данных о регистрации представлена в таблице

    Таблица  – Структура файла данных о регистрации импульсных приборов..

    № п/п Поле Комментарий
    1 Номер квартиры подробнее см. раздел 2.3
    2 Тип счетчика

    Х, Г, О, Э

    Или 1 – ХВС, 2 – ГВС, 3 – Отопление, 4 – Электричество.

    3 Серийный номер прибора Только цифры. Если неизвестен – 0.
    4 Идентификатор прибора учета в БД ID прибора в Настройка / Импульсные расходомеры
    5 Номер концентратора Номер концентратора (КИР или КИР-КМ), к входу которого подключен данный прибор учета.
    6 Номер канала Номер входа концентратора, к которому подключен прибор учета
    7 Комментарий До 32 символов (необязательный параметр)
    8 Концентратор КИР-РП Номер концентратора КИР-КП
    9 MAC КИР-РП МАС адрес концентратора КИР-РП
    10 Облако Канал облака КИР-РП

    1;X;12345;1;101;1
    Пример CSV-файла данных о регистрацииПоля 8-10 обязательны для заполнения только для радио-концентраторов (КИР-КМ + КИР-РП). Пример файла приведен в таблице 3.

    1;Г;123458;2;101;2
    2;1;55555;1;102;1
    2;3;54555;2;102;2

    Перед выполнением импорта данных обязательно должны быть зарегистрированы все импульсные приборы учета с помощью меню Настройка \ Импульсные расходомеры.

    Данные о показаниях
    Структура файла данных о показаниях импульсных приборов представлена в таблице 4.

    Таблица  – Структура файла данных о показаниях импульсных приборов учета

    № п/п Поле Комментарий
    1 Серийный номер Серийный номер прибора учета (только цифры)
    2 Тип данных 1 – по акту ввода прибора, 2 – корректирующее
    3 Показание Показание прибора учета
    4 Дата / время снятия Дата / время в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС
    5 Тариф 1 – первый тариф, 2 – второй тариф

    Подробнее о показаниях см. далее раздел Показания импульсных приборов учета.где под корректирующем значением понимается показание прибора, зафиксированное обходчиком.

    Данные серийных номеров

    В случае если первоначально в системе не были введены серийные номера приборов учета. Следует:

    • Включить сохранение отчетов в формате CSV. Меню Отчеты / Настройка отчетов, опция Сохранять отчеты в формате CSV.
    • Cформировать отчет Отчеты / Оборудование.
    • Отредактировать файл DBase\Оборудование.csv, например, в Excel, указав корректные серийные номера приборов учета.
    • Импортировать измененный файл.

    Данные ADFWeb

    Смотри сайт wiki.tekon.ru раздел Интеграция, подраздел M-bus - Опрос приборов учета через ADFWEB HD67044

    Информации о ЦТП

    Программа позволяет указать привязку зарегистрированных домов к ЦТП. Данная информация используется в ряде отчетов по общедомовым теплосчетчикам. 

    Для осуществления привязки следует после регистрации адресной информации перейти в окно Шаг 1 (пароль должен быть введен).

    Далее следует нажать правой кнопкой мыши в окне ЦТП слева и в появившемся меню выбрать Добавить.

    Ввести номер ЦТП и по необходимости номер договора в скобках. Далее выбрать дом слева и перетащить его на созданный ЦТП. Аналогично для следующих домов.
     

    Asudbase 15.png

    Рисунок – Окно регистрации ЦТП.

    В случае если ЦТП несколько, аналогичным образом добавить следующие ЦТП.

    Для указания одного номера договора для всех ЦТП выбрать меню Один договор на все ЦТП.

    Для удаления привязки дома к ЦТП следует выбрать дом и выбрать меню Удалить.

    Для удаления всей информации о привязках к ЦТП выбрать меню Удалить все.

    Дополнительные настройки программы

    Рассмотрим остальные разделы меню Настройка
     

     

    Изменение пароля на доступ в режим настройках

    Для изменения пароля по умолчанию («0000») на доступ к настройкам, следует выбрать меню Настройка \ Новый пароль и указать новый пароль.


    Настройка параметров оценки качества предоставляемых услуг Отопление \ ГВС

    Система позволяет провести анализ качества предоставляемых услуг Отопление \ ГВС согласно приложению N 1 к ПП РФ от 06.05.2011 N 354 «О предоставления коммунальных услуг собственникам и пользователям помещений в многоквартирных домах и жилых домов».

    Для настройки системы анализа качества, необходимо ввести в систему температурные графики ЦО (согласованные с ресурсоснабжающей организацией), а также данные о температуре окружающей среды.

    Открыть меню Настройка \ Температурные графики. 

    В открывшемся окне на вкладке Данные метеослужбы следует указать данные о температуре окружающей среды.
     

    Asudbase 16.png

    Рисунок – Данные метеослужбы.

    Кнопка Прочитать читает ранее введенные данные на указанном интервале. Кнопка Заполнить даты - заполняет поле Дата в таблице показаний, значения температур необходимо вводить самостоятельно.

    Вкладка Температурные графики ЦО содержит таблицу зависимостей температуры теплоносителя от температуры наружного воздуха. 


    Asudbase 17.png

    Рисунок – Данные температурных графиков ЦО.

    В соответствии с полученной таблицей зависимости в ресурсоснабжающей организации следует заполнить требуемые таблицы данными.

    Введенные данные используются при построении отчета Отчеты \ Качество услуг  и отчета Отчеты \ Архив системы.


    Настройка специальных параметров.

    Меню Настройка \ Специальные параметры.

    Резервный раздел. Использовать не следует.

    Настройка специальных систем.

    Меню Настройка \ Специальные системы.

    Резервный раздел. Использовать не следует.

    Архивирование мгновенных значений.

    По умолчанию в БД заносятся только архивные данные подключенных приборов учета. 

    Мгновенные (текущие) результаты измерений выполненные прибором учета не добавляются к архиву БД, а хранится только 1 последняя запись данных измерений (отображаемая во вкладке Мгн. окна Шаг 2).

    В случае если возникает (по каким то причинам) необходимость так же хранить и архив мгновенных измерений, следует выполнить активацию данного функционала (это в частности позволит строить график мгновенных значений).

    Для вкл./откл. записи мгновенных значений программа должна быть запущена под пользователем с административными правами в монопольном режиме доступа к БД (подробнее см. пункт монопольный режим доступа к БД).

    Далее следует включить запись мгновенных значений: меню Настройка \ Мгновенные значения \ Разрешить.

    Мгновенные значения сохраняются в отдельный файл C:\DB\RASHOD_M

    Периодически следует проверять размер данного файла с помощью меню Настройка \ Мгновенные значения \ Информация.

    Если размер файла стал слишком большой (наблюдаются задержки при построении графиков мгновенных значений), следует создать новый файл с помощью меню Настройка \ Мгновенные значения \ Новый файл.

    Для отключения записи мгновенных значений следует снять флажок (повторно выбрать) меню Настройка \ Мгновенные значения \ Разрешить.



    Специальные функции работы с БД

    Рассмотрим разделы меню Настройка / Работа с БД

    Таблица – элементы меню Настройка / Работа с БД

    Элемент меню Описание
    Обновление Выполнить обновление БД (подробнее см. раздел 1.3)
    Добавить новые типы устройств Выполнить обновление списка поддерживаемых приборов учета.
    Резервирование Выполнить создание резервной копии БД 
    Восстановление Выполнить восстановление БД из резервной копии
    Консоль Выполнить подключение к БД в режиме SQL-консоли (исп. для служебных целей)
    Ремонт Выполнить Ремонт БД (подробнее см. документ «Ремонт базы данных»)
    Сброс версии Выполнить сброс версии БД на указанный номер (исп. Для служебных целей)
    Экспорт данных Все данные расхода с указанной даты будут сохранены в специальном файле DBase\export.dts
    Импорт данных Загрузить данные расхода, сохраненные в специальном файле *.dts
    Экспорт настроек Сохранить настройки регистрации приборов учета в специальном файле
    Импорт настроек Импортировать настройки регистрации приборов учета. Только для пустой БД.

    Отдельно рассмотрим функции позволяющие выполнить очистку БД.

    Удаление «старых» параметров.

    При выборе меню Настройка / Работа с БД / Удалить старые параметры будут удалены данные вкладки  Мгн. (мгновенные значения), которые не обновляются долгое время (например, в связи переконфигурированием прибора учета и отсутствии данных параметров в новой конфигурации прибора). 

    Удаление архива данных

    Существует возможность удалить архивные данные всех зарегистрированных приборов учета. При этом информация о регистрации приборов останется в БД. Для этого выберете раздел Настройка\Работа с БД\Удалить данные. При этом фактически будет создан новый файл БД, содержащий только конфигурационную информацию о зарегистрированных приборах учета.

    Удаление всей информации

    Для выполнения полной очистки БД необходимо выбрать меню Настройка\Работа с БД\Очистить БД. При этом будет создан новый пустой файл БД. Существующий файл БД будет переименован.

    Опции быстрого редактирования

    При введенном пароле (меню Файл / Ввод пароля) во вкладке Шаг 2 при нажатии правой кнопкой мыши открывается меню с опциями быстрого изменения ряда параметров для выбранной системы учета.

    -> ХВС, ГВС, Отопление - изменить тип выбранной системы на указанную.
    Номер прибора   изменить номер прибора.
    Комментарий - изменить комментарий.
    Удалить данные - удалить все архивные данные выбранной системы.
    Удалить контур - удалить выбранную систему.
    Экспорт / Импорт данных - сохранить/загрузить данные системы.


    Настройка отчетов

    В окне Отчеты \ Настройка отчетов доступны ряд параметром используемые при формировании табличных отчетов и экспорте данных. Доступ к настройке возможен только после ввода пароля.

    Asudbase 17.1.png

    Рисунок – Настройка отчетов. Вкладка Общие.

    Во вкладке Общие отображаются настройки отчетов тепло- водопотребления. 

    Asudbase 17.2.png

    Рисунок – Настройка отчетов. Вкладка Дополнительно.

    Asudbase 17.3.png

    Рисунок – Настройка отчетов. Вкладка ЭНЕРГОСБЫТ.

    Число тарифов электросчетчиков - максимальное число тарифов отображаемых в отчетах.

    ASQ   служебные параметры файла экспорта данных квартирных электросчетчиков.


    ПОКАЗАНИЯ ИМПУЛЬСНОГО ПРИБОРА УЧЕТА

    Как уже было отмечено ранее, для возможности вычисления последующих показаний импульсных приборов учета, подключенных к концентраторам КИР, необходимо чтобы в систему было введено первоначальное показания отображаемое непосредственно на приборе учета.

    Показания могут введены путем импорта файла показаний (как было показано ранее) или отредактированы вручную.

    Для редактирования показаний следует выбрать требуемый прибор учета на Шаге2 и нажать кнопку «И».


    Asudbase 18.png

    Рисунок – Выбор импульсного прибора учета.

    Определены три типа показаний прибора учета:

    • Показания при вводе в эксплуатацию   первоначальное показание прибора учета при вводе системы в эксплуатацию.
    • Корректирующее   показания зафиксированные в результате обхода.
    • Вычисленные   показания рассчитанные системой автоматически при формировании отчетов (редактировать их не следует).

    С точки зрения расчета последующего показания прибора учета   все указанные типы показаний равнозначны. При расчете последующего показания система берет самое ближайшее (к дате расчета) показание и использует его в качестве отсчетного для вычисления по формуле 2 (см. раздел 1.5).

    Соответственно самое первое показание следует ввести в поле «Ввод в эксплуатацию», все последующие показания в таблицу «Корректирующих значений».

    Asudbase 19.png

    Рисунок – Показания импульсного прибора учета.

    Для ввода корректирующего показания следует: выбрать тип - «Корректирующие», нажать кнопку плюс «+» и ввести дату снятия показания и показание прибора учета. Нажать Галочку для подтверждения ввода данных.

    Следует иметь ввиду, что все показания вводятся на 24:00, т.е. если дата указана как 31.03.2014, то считается что это 31.03.2014 24:00, т.е. 01.04.2014 00 часов.

    Тариф может быть указан только для электросчетчиков.

    Кнопка «Текущие» позволяет определить текущие показания прибора учета.

    Кнопка «?» - отображает краткую справочную информацию.

    Кнопка «Коррекция на 24:00» позволяет скорректировать навое показание на 24:00 предыдущего дня, что позволяет более точно ввести показание прибора в систему.

    Так, например, обходчик списал показание прибора 174 куб.м., 20.08.2014 в 15-00, далее если просто ввести их как Корректирующие, то при указании даты 20.08.2014  (фактически 21.08.2014 00 часов) - получится, что расход с 15-00 по 24-00 не будет учтен. Если указать дату 19.08.2014 то новые вычисленные показания будут больше на величину расхода с 00 часов по 15 часов 20.08.2014. В принципе это расхождение не критично, но система позволяет его устранить. Для этого после выбора типа «Корректирующие» следует нажать кнопку «Коррекция», в открывшемся окне ввести время снятия показаний и показание, нажать «Пересчет». Система рассчитает показание на 20.08.2014 00 часов, с учетом расхода с 00 часов по 15 часов. И далее предложит его записать на 19.08.2014 24:00.

    Asudbase 20.png

    Рисунок – Коррекция показания импульсного прибора учета .

    ДОПОЛНИТЕЛЬНО

    Поиск устройства, зарегистрированного в БД.

    Для поиска устройства можно воспользоваться меню Дополнительно / Поиск концентратора, будет предложено ввести номер концентратора или его IP-адрес, в результате поиска система отобразит адрес регистрации данного концентратора.

    Если к каналам концентратора подключены разные приборы учета, установленные в разных квартирах, будут перечислены все эти приборы учета.
    Asudbase 21.png

    Рисунок – Окно поиска концентратора по номеру.

    Для поиска устройства по его серийному номеру следует открыть меню Дополнительно / Поиск прибора по номеру, будет предложено ввести номер устройства, в результате поиска система отобразит адрес регистрации данного прибора учета, номер концентратора, к которому подключен прибор.
    Asudbase 22.png

    Рисунок – Окно поиска прибора по серийному номеру.

    Если к каналам концентратора подключены разные приборы учета, установленные в разных квартирах, будут перечислены все эти приборы учета.


    Справочная информация

    Раздел главного меню Справка, содержит справочную информацию.

    Меню Справка / О программе  - открывает окно с информацией о версии программы, контрольно суммы, контактными телефонами.


    Asudbase 23.png

    Рисунок – Окно О программе.

    Меню Справка / Справка   открывает окно краткой информации о последних изменениях в программе ASUDBase.

    Asudbase 24.png

    Рисунок – Окно Справка.

    Меню Справка / О базе данных   открывает окно краткой информации о базе данных, к которой подключена программа.

    Asudbase 25.png

    Рисунок – Окно информация о базе данных.

    Первая строка - полный путь к файлу БД.

    Версия   текущая версия БД (подробнее см. обновление БД). Обновление - обновление БД доступное в данной программе. Для нормальной работы программы необходимо, чтобы Версия = Обновлению.

    MD5 хеш    контрольная сумма версии БД.

    Число подключений   число подключений к БД. Программа ASUDBase - 1 подключение, при подключении ОРС-сервера число подключений увеличится до трех. Для выполнения ряда операций  (например, обновления БД) требуется, чтобы к БД не были подключены прочие приложения, кроме программы ASUDBase (см. раздел монопольный режим доступа к БД).

    Page size, ODS - служебная информация. Одинакова для всех БД в настоящее время.

    НЕКОТОРЫЕ ОСОБЕННОСТИ РАБОТЫ С БАЗОЙ ДАННЫХ
     

    Монопольный режим доступа к БД

    В некоторых случаях для работы программы ASUDBase необходимо, чтобы никакие другие программы не были подключены к базе данных (например, при выполнении операции обновления БД или включении архивирования мгновенных значений и т.д). 

    Для отключения клиентов от БД необходимо:

    1. Закрыть программу KCSLogger (если используется).
    2. Закрыть программу RClient (если используется).
    3. Закрыть программу SCADA.
    4. Запустить конфигуратор ОРС-сервера («Настройка ОРС-сервера) и свернуть его.

    После выполнения операций требующих монопольного доступа к БД, следует закрыть конфигуратор ОРС-сервера и запустить рабочие программы.

    Копирование БД

    В случае необходимости выполнить копирование рабочего файла БД original.gdb следует в обязательном порядке отключить всех клиентов БД (см. раздел ранее).  

    Проверить в программе ASUDBase меню Справка / О базе данных, что число подключений равно 1.Закрыть программу ASUDBase.

    Выполнить копирование файла БД штатными средствами операционной системы. При необходимости файл можно сжать с помощью архиватора zip.

    ПРИЛОЖЕНИЕ А

    Регистрация различного типа приборов в БД


    Пример1: Регистрация теплосчетчика («ВИСТ»), подключенного к КЦС.

    Выбрать улицу, дом.

    Asudbase A11.png

     

    В «Концентратор \ Прибор» указать номер концентратора КЦС и тип теплосчетчика. Нажать «Добавить».

    Asudbase A12.png

    Выбрать слева зарегистрированный теплосчетчик «804 ВИС.Т».

    Asudbase A13.png

    Справа в «Прибор» указать канал 2, серийный номер прибора (если известен), тип системы (ГВС), поле квартира оставить 0. Нажать «Добавить».

    Asudbase A14.png

    Справа в «Прибор» указать канал 3, серийный номер прибора (если известен), тип системы (ХВС), поле квартира оставить 0. Нажать «Добавить».

    Asudbase A15.png


    Пример2: Регистрация теплосчетчика («ВИСТ»), подключенного к КЦС-IPМ.

    Выбрать улицу, дом.

    Asudbase A11.png

    Справа установить галочку «IP-соединение» (при этом номер концентратора будет проставлен автоматически). Выбрать прибор «ВИС.Т». Указать мастер устройство «КЦС-IPМ». Указать параметры соединения. Указать интервал обновления мгновенных значений (рекомендуется устанавливать значение не менее 15 минут). Нажать добавить.

    Asudbase A22.png

     

    Asudbase A23.png

    Выбрать слева зарегистрированный теплосчетчик «8902 ВИС.Т».

    Справа в «Прибор» указать канал 2, серийный номер прибора (если известен), тип системы (ГВС), поле квартира оставить 0. Нажать «Добавить». Справа в «Прибор» указать канал 3, серийный номер прибора (если известен), тип системы (ХВС), поле квартира оставить 0. Нажать «Добавить».



    Пример3: Регистрация электросчетчика («Меркурий 200»), подключенного к КЦС-IPM.

    Выбрать улицу, дом.

    Asudbase A31.png

    Справа установить галочку «IP-соединение» (при этом номер концентратора будет проставлен автоматически). Выбрать прибор «Меркурий 200». Указать мастер устройство «КЦС-IPМ». Указать параметры соединения. Указать интервал обновления мгновенных значений (рекомендуется устанавливать значение не менее 15 минут). Нажать добавить.

    Asudbase A32.png

    Выбрать слева появившийся канал «1 Электроэнергия». Справа в «Прибор» указать: квартиру, лицевой счет. Нажать «Изменить» для подтверждения изменений.

    Asudbase A33.png

     


    Пример4: Регистрация импульсного квартирного водосчетчика, подключенного к КИР16.

    Выбрать улицу, дом. В «Концентратор \ Прибор» указать номер концентратора КИР-16 и тип прибора «Импульсный». Нажать «Добавить».

    Asudbase A41.png

    Выбрать слева зарегистрированный прибор «805». Справа следует последовательно указать номера каналов КИР и типы приборов учета, подключенные к данным входам КИР, номер квартиры, где расположены данные приборы. Нажать «Добавить».

    Asudbase A42.png

    Аналогично для следующего канала.

    Asudbase A43.png


    ПРИЛОЖЕНИЕ Б

    Параметры запуска программы 
    (запуск из командной строки)

    1. Сформировать файл отчета за указанный интервал и закрыть программу.
    Asudbase.exe /auto ReportID HouseID Date1 Date2 ReportFileName
    ReportID - идентификатор отчета:
        1 - Отчеты \ Расход по каждому ИПУ. Все
        2 - Отчеты \ Расход по каждому ИПУ. Вода
        3 - Отчеты \ Расход по каждому ИПУ. Отопление
        4 - Отчеты \ Расход по каждому ИПУ. Электричество
        5 - Отчеты \ Показания ИПУ
        6 - Отчеты \ Поквартирно \ ГВС/ХВС/ХВС* - временно нет.
        7 - Отчеты \ Поквартирно \ ГВС/ХВС
        8 - Отчеты \ Поквартирно \ ГВС/ХВС (нжп)
        9 - Отчеты \ Поквартирно \ ГВС/ХВС (моп)
        10 - Отчеты \ Поквартирно \ ГВС/ХВС показания - временно нет. 
        11 - Отчеты \ Поквартирно \ Отопление

    HouseID - идентификатор дома. Может быть просмотрен в окне Шаг 2 рядом с надписью «Анализируемые системы» (правый верхний угол) при введенном пароле.

    Date1 Date2 - левая и правая граница даты интервала отчета в формате DDMMYYY. 

    ReportFileName - имя CSV-файла сформированного отчета. Отчет будет сохранен в папке DBase\.

     

    2. Сформировать файл отчета за предопределенный интервал и закрыть программу.
    Asudbase.exe /auto Interval ReportID HouseID ReportFileName
     

    Interval
        cd - текущий день
        cm - текущий месяц
        lastd - предыдущий день
        lastm - предыдущий месяц

    Остальные параметры аналогичны пункту 1.